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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.
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1
Introduction to the LabVIEW
Datalogging and Supervisory
Control Module

The LabVIEW Datalogging and Supervisory Control module is an add-on
to LabVIEW that adds features and capabilities to help you create high
channel count applications. It provides solutions for supervisory control of
a wide variety of distributed systems using the flexibility of graphical and
LabVIEW programming.

Why Should I Use the LabVIEW Datalogging
and Supervisory Control Module?

The LabVIEW Datalogging and Supervisory Control module adds the
following features and capabilities to LabVIEW:

• Configuration utilities and wizards

• Real-time database

• Historical data collection and trending

• Alarm and event reporting and logging

• Security

• Connection to PLC and industrial device networks

• OPC server and client

• Connection to a wide selection of device servers
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How Does the Datalogging and Supervisory
Control Module Work?

You build applications with the LabVIEW Datalogging and Supervisory
Control module the same way you build them in LabVIEW, with added
controls, functions, and utilities that help you accomplish certain tasks
more efficiently.

Controls and Indicators
The LabVIEW Datalogging and Supervisory Control module installs the
following subpalettes on the Controls palette.

• Vessels—Several tanks, a hopper, and a bin. All objects on this
subpalette are numeric.

• Pipes, Pumps, & Valves—Various Boolean pipe, pump, and valve
objects.

• Alarms and Events—A set of displays, formatting tools, and
summary tools for handling alarms and events.

• Trends—Historical trend XY graph and real-time trend waveform
chart.

• DSC Server Data Types—Various server objects, including item
spec, output queue data, input queue data, item access rights, and
group spec.

Functions
The LabVIEW Datalogging and Supervisory Control module installs the
following subpalettes on the Functions palette. Refer to the LabVIEW
Datalogging and Supervisory Control Module Help for more information
about the VIs and functions on these subpalettes.

• Tags—Use these VIs and functions to read the most recent value of a
tag, write a new value to a tag, or obtain data for a real-time trend.

• Alarms & Events—Use these VIs to acknowledge alarms, display
alarm summary or event history information, or obtain alarm summary
status.

• Tag Attributes—Use these VIs to read and write tag configuration
parameters programmatically.

• Historical Data—Use these VIs to read and write historical data about
a tag, to resample trend data, compute statistical data for a historical
trend, or convert historical trend data to a spreadsheet.
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• System—Use these VIs to obtain information about or monitor the
access level of current operator, launch or shut down LabVIEW, and
enable or disable event logging, historical datalogging, or printing.

• System»Security—Use these VIs to implement security in your
application.

• DSC Server Development—Use these VIs to configure the server
interface and server registration programmatically.

Utilities
The LabVIEW Datalogging and Supervisory Control module installs the
following tools and utilities.

Tag Utilities Toolbar
Use the Tag Utilities floating toolbar to open other LabVIEW Datalogging
and Supervisory Control module utilities without selecting them through
the menus.

Tag Configuration Editor
Use the Tag Configuration Editor to create, edit, or delete all of the tags in
the LabVIEW Datalogging and Supervisory Control module system and to
configure Tag Engine parameters. The Tag Configuration Editor records all
tag information and Tag Engine parameters and stores it in a configuration
(.scf) file. The Tag Engine reads this file to determine all of the
configuration parameters for execution.

Tag Monitor
Use the Tag Monitor to monitor the value, timestamp, alarm state, and
connection status for selected tags in the system and to write the value to
an output or input/output tag.

Tag Engine
The Tag Engine runs as a separate process, independent of the HMI
application, communicating between device servers on one end and
the HMI application at the other end.

The Tag Engine performs the main tasks for the LabVIEW Datalogging
and Supervisory Control module, including the following:

• Communicates with device servers

• Scales and initializes data
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• Processes alarms

• Logs alarms and events to the Citadel historical database

• Collects and trends historical data

Citadel Historical Database
Citadel is a National Instruments database used by the LabVIEW
Datalogging and Supervisory Control module, Lookout, and other National
Instruments products. It efficiently stores data acquired and processed by
applications.

Historical Trend Viewer
Use the Historical Trend Viewer (HTV) to view the data stored in the
Citadel database.

Real-Time Database
The real-time database (RTDB) is a snapshot of the state of all tags defined
in the active .scf file. The RTDB stores the tag values, status, date, time,
and alarm information.

User Manager
Use the User Manager to set up and edit individual accounts for users and
groups of users who use either the LabVIEW Datalogging and Supervisory
Control module or the applications you create with it. Use the User
Manager to create an account for a user, assign a password, control how
long the password is valid, set the security level for that user, and determine
which security group or groups that user belongs to.

Server Browser
In the LabVIEW Datalogging and Supervisory Control module, a device
server is an application that communicates with and manages I/O devices
such as PLCs, remote I/O devices, remote Tag Engines, and data
acquisition (DAQ) plug-in devices. These servers read selected input items
and write to them on demand. Use the Server Browser to see the device
servers in a computer and in other computers on the network. You can view
server information and display the front panel of VI servers (if the server is
running), launch server configuration software for compatible servers,
change OPC settings, and unregister a server.
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Image Navigator
Use the Image Navigator to browse through a collection of images you can
use to create front panels.

Where Do I Start?
If you are not familiar with LabVIEW, start with the LabVIEW
documentation, tutorial, and examples. When you are familiar with
LabVIEW, complete the activities in this manual. You can also refer to
the LabVIEW Datalogging and Supervisory Control Module Developer’s
Manual and online help. For additional guidance, you can study the
LabVIEW Datalogging and Supervisory Control module examples in the
LabVIEW 6\Examples\lvdsc directory.
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2
Graphical User Interface

This chapter teaches you how to create a graphical user interface using the
LabVIEW Datalogging and Supervisory Control module.

You will learn to do the following:

• Open and run a VI to explore the functionality of the LabVIEW
Datalogging and Supervisory Control module

• Build a front panel using LabVIEW Datalogging and Supervisory
Control module features

• Connect front panel controls to a server

Open and Run a VI
This activity helps you familiarize yourself with the functionality of the
LabVIEW Datalogging and Supervisory Control module.

You can complete this activity in approximately 5 minutes.

1. Select File»Open, and open the Manufacturing VI in the
LabVIEW 6\examples\lvdsc\apps\Manufacturing directory.

2. Type Guest in the Username field of the User Login dialog box.

3. Click the Run button to run the VI.

4. Click various screen elements to practice using the front panel and
block diagram. Right-click to display the Controls palette on the front
panel and the Functions palette on the block diagram. Select
Window»Show Tools Palette to display the Tools palette.

5. Stop the VI.

6. Stop the Tag Engine by right-clicking the Tag Engine icon on the
Windows taskbar and selecting Stop.
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Build the Graphical User Interface
This activity teaches you how to build a simple front panel to interface with
the OPC Demo server.

You can complete this activity in approximately 10 minutes.

Build the front panel as shown in the following figure.

1. Create a new VI by selecting New VI from the LabVIEW dialog box,
or by selecting File»New VI from the front panel or block diagram.

Make sure to display the Tools palette by selecting Windows»
Show Tools Palette, and Tag Utilities toolbar by selecting
Tools»Datalogging & Supervisory Control»Show Toolbar.

2. Click the Image Navigator button on the Tag Utilities toolbar to launch
the Image Navigator, a feature of the LabVIEW Datalogging and
Supervisory Control module.
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3. Select Pumps from the Categories list of the Image Navigator. Select
the Heavy-duty plastic centrifugal pump from the Symbols box.
Click Options if you want to change the color and orientation.

4. Click Copy and close the Image Navigator.

5. Select Edit»Paste to place the graphic on the front panel.

6. Navigate to the Numeric subpalette of the Controls palette, as shown
in the following figure.

7. Select and place a Knob on the front panel. To show the digital display,
right-click the Knob and select Visible Items»Digital Display. Select
and place a Gauge on the front panel.

8. Navigate to the Boolean subpalette of the Controls palette.

9. Select and place the Square LED from the Boolean subpalette on the
front panel, and label it MotorRPMLimit. Select and place three Push
Button controls on the front panel. Select and place the OK Button on
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the front panel, and label it Login. Use the Text tool to change the
button text.

10. Navigate to the Decorations subpalette of the Controls palette.

11. Add decorations to the front panel to recreate the front panel shown at
the beginning of the exercise. Use tools from the Tools palette to resize
and label front panel objects. Refer to the LabVIEW Help for more
information about the Tools palette.

Note If the label is not present, right-click the object and select Show Label from the
shortcut menu.

12. When your front panel matches the front panel shown in step one,
select File»Save and save as Compressor.vi in the LabVIEW 6\ 

examples\lvdsc folder.

Connect the Front Panel Controls to the
OPC Demo Server

This activity demonstrates how to connect the OPC Demo server I/Os with
the controls and indicators on the front panel of the Compressor VI created
in the previous section.

You can complete this activity in approximately 5 minutes.

1. Make sure that the Tag Engine is not running when you open the
Compressor VI. If it is, right-click the Tag Engine icon in the Windows
taskbar and select Stop.
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2. Open the Compressor VI and display the Controls palette, Tools
palette, and Tag Utilities toolbar.

3. Click the Start Tag Configuration Editor button, on the Tag Utilities
toolbar, to launch the Tag Configuration Editor. Select File»New to
create a new .scf file.

4. Save the file as Compressor.scf in the LabVIEW 6 folder. Click OK
in the SCF Logging Paths dialog box. Close the Tag Configuration
Editor.

5. Right-click the Knob and select HMI Wizard. The HMI Wizard for
Analog Control dialog box appears.

6. Use tags to create and maintain a connection to a real-world I/O point.
Click the Create New Tag button in the HMI Wizard for Analog
Control dialog box to select the item you want to connect to.

7. Select National Instruments OPCDemo»NI OPC Demo
Server»Simulation»MotorRPMSetPoint, as shown in the following
figure. Click OK.
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8. Click OK again. The configuration file is saved. Click OK.

9. Repeat steps 5 through 7 for the Gauge, selecting MotorRPMSensor
from Simulation this time. The LED will be connected later.

10. Click the Run button to run the VI. This launches the Tag Engine.

11. Turn the MotorRPMSetPoint knob and notice that the
MotorRPMSensor adjusts accordingly.

12. Click the Stop button to stop the VI. Save and close the VI.

13. Right-click the Engine Manager icon and select Stop to stop the Tag
Engine.

Note When you build your application, you can also use the Tags VIs and the Tag
Attribute VIs on the Functions palette to read tag values, write to tags, access their
attributes, and perform other tag operations.
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3
Real-Time Trending

This chapter teaches you how to view data values using the LabVIEW
Datalogging and Supervisory Control module Real-Time Trend
capabilities.

View Real-Time Data
This activity demonstrates how to view real-time data using a Real-Time
Trend.

You can complete this activity in approximately 7 minutes.

Create the Real-Time Trend Viewing Panel
Build the following front panel.

1. Select File»New from any open window or click the New File button
on the Tag Utilities toolbar.

2. Display the Tools palette by selecting Windows»Show Tools Palette
and the Controls palette by right-clicking anywhere on the front panel.
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3. Select and place the Real-Time Trend from the Trends subpalette on
the front panel and label it Real-Time Trend.

4. Right-click the Real-Time Trend and select HMI Wizard. Select
MotorRPMSensor and click Add to add it to the Tag List. Repeat for
MotorRPMSetPoint. Click OK to close.

5. Select and place an OK Button from the Boolean subpalette on the
front panel.

6. Save this VI as Real Time Trend.vi in the
LabVIEW 6\examples\lvdsc folder.

7. Right-click the OK button and select Panel Wizard. Select Close this
Panel from the With this Control pull-down menu. Click OK to close
the Panel Wizard dialog box.

The button text changes from OK to Close.

8. Save the VI.
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Connect the Viewing Panel to the Application
1. Open the Compressor VI that you created in Chapter 2. You will use

this VI to make a connection to the Real-Time button.

2. Right-click the Real-Time Trending button and select Panel Wizard.

3. Select the VI radio button on the Panel tab. Click Browse then
navigate to, and double-click Real Time Trend.vi. Click OK to close
the Panel Wizard.

Notice that the button text has changed to Real Time Trend.vi.

4. Click the Run button to run the Compressor VI. To view the real-time
trends, click the Real-Time Trending button. Now, you can see the
real-time trend of the tags. Move the knob on the front panel and notice
the movement of the gauge.

5. Stop and save the Compressor VI and the Real Time Trend VI.
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4
Historical Logging

This chapter teaches you how to log and view data values with the
LabVIEW Datalogging and Supervisory Control module special features.

You will learn to do the following:

• Specify which items to log

• Use a Historical Trend Viewer to view logged data

Log I/O to the Database
This activity demonstrates how to specify which items are logged by the
LabVIEW Datalogging and Supervisory Control module. By default, all
data is logged to the Citadel database. If you do not want to log the data of
a specific tag, you can change its configuration.

You can complete this activity in approximately 3 minutes.

1. Open the Compressor VI. Make sure the Controls Palette, Tools
Palette, and Tag Utilities toolbar are display.

2. Click the Start Tag Configuration Editor button on the Tag Utilities
toolbar to open the Tag Configuration Editor.

3. Double-click MotorRPMSetPoint.

4. Click the Operations tab and deselect Log Data. Click OK.

5. Select File»Save. If the Tag Engine is still running, you are asked to
update the .scf file. Click Yes to update it. Close the Tag
Configuration Editor.

6. Save the Compressor VI.
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View Logged Data Using the Historical
Trend Viewer (HTV)

This activity demonstrates how to view the data being logged, using the
Historical Trend Viewer (HTV).

You can complete this activity in approximately 5 minutes.

1. Open the Compressor VI if it is not already open.

2. Right-click the Historical Trend Viewer button and select Panel
Wizard.

3. Select Historical Trend Viewer and click OK.

4. Click the Run button. To view the historical data, click the Historical
Trend Viewer button.

5. Select MotorRPMSensor from the list of Available Tags and click
Add, as shown in the following figure. Click OK.

Note The selected tag appears on the right side. You can show a maximum of eight tags
in the HTV at a time.

The logged data for the tags appears in the Historical Trend Viewer.
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6. Click the magnifying glass icon and select a setting to zoom into a
section of the data.

7. Move the triangular cursors at the bottom of the graph. Note that the
changing corresponding values and timestamps appear in the Data
Display.

8. Click the skip button to view the end of the data set.

9. Select Viewer»Preferences and change the Scroll time to
1.00 second.

10. Click the Live button.

Now, the Historical Trend Viewer is performing as a real-time trend
viewer. New values are updated in the display as they are logged. Turn
the knob on the front panel to view the trend.

Note You can also call the Historical Trend Viewer programmatically with the Call HTV
VI in the Functions»Historical Data palette. Use other VIs in this palette to extract and
decimate data from the database, obtain a list of tags that have logged data, and convert the
data into spreadsheet format.

11. Close the Historic Trend Viewer.

12. Stop the VI. Note that the Tag Engine keeps running and logging data
by the Engine Manager icon in the Windows taskbar. Save and close
the VI.
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5
Alarms

This chapter teaches you how to use the basic alarm capabilities of the
LabVIEW Datalogging and Supervisory Control module.

You will learn to do the following:

• Configure, view, and acknowledge alarms

• Add alarm functionality to an existing VI

Set and View Alarms
This activity demonstrates how to configure, view, and acknowledge
alarms using utilities of the LabVIEW Datalogging and Supervisory
Control module.

You can complete this activity in approximately 5 minutes.

1. Open the Compressor VI. Display the Controls palette, Tools palette,
and Tag Utilities taskbar.

2. Click the Start Tag Configuration Editor button on the Tag Utilities
toolbar to open the Tag Configuration Editor.

3. Double-click MotorRPMSensor and select the Alarms tab.
Configure the alarm characteristics as shown in the following figure.
Click OK.
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4. Select File»Save. If the Tag Engine is still running, you are asked to
update the .scf file. Click Yes to update. Close the Tag Configuration
Editor.

5. Right-click the Alarms button on the front panel of the Compressor VI
and select Panel Wizard.

6. Select the Tag Monitor radio button on the Panel tab. Click OK.
The Alarms label text changes to Tag Monitor. Use the Text tool to
change it back to Alarms.

7. Click the Run button to run the VI. To view the alarms, click the
Alarms button, which launches the Tag Monitor.
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8. Drag and drop the MotorRPMSensor and MotorRPMSetPoint
items from the left tree view to the right side of the window. The
alarms will display in the bottom list of the Tag Monitor dialog box,
as shown in the following figure.

9. To acknowledge the alarms, right-click any alarm and select
Acknowledge from the shortcut menu. You can enter comments.
Close the Tag Monitor.

10. Stop the VI and save any changes, then close the VI.

Note You can also filter the alarms by right-clicking an alarm and selecting Filter
Options.

Add Alarm Functionality to an Existing VI
This activity demonstrates how to add alarm functionality to an existing VI
using the alarm functions of the LabVIEW Datalogging and Supervisory
Control module. To add functionality to your existing VI, access the block
diagram and add graphical code. This activity demonstrates how to turn on
the MotorRPMLimit LED when MotorRPMSensor is in alarm.

You can complete this activity in approximately 7 minutes.

1. Open the Compressor VI. Display the Controls palette, Tools palette,
and Tag Utilities toolbar.

2. Right-click MotorRPMLimit and select Find Terminal.
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3. Build the following block diagram in the same window as the
Compressor VI block diagram.

4. Select Window»Show Panel and click the Run button to run the VI.

5. Turn the MotorRPMSetPoint knob on your front panel. Notice that
the MotorRPMLimit lights up when MotorRPMSensor is in alarm.

6. Stop the VI. Save and close the VI.

7. Right-click the Engine Manager icon in the Windows task bar and
select Stop to stop the Tag Engine.
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6
Security

This chapter teaches you how to use some of the security features included
in the LabVIEW Datalogging and Supervisory Control module.

You will learn to do the following:

• Create user accounts

• Implement security on a front panel

Add Security to Your System
This activity demonstrates how to create user accounts and implement
security for your front panel. A Login button will limit access to front panel
objects based on the password-based user accounts.

You can complete this activity in approximately 10 minutes.

1. Open the Compressor VI.

2. Create user accounts by selecting Tools»Datalogging & Supervisory
Control»Security»Edit User Accounts.

Note If you were not previously logged in, the User Login dialog box appears. Select
Administrator from the Accounts pull-down menu of the User Login dialog box.

3. Select User»New User in the User Manager window.

4. Create the following two new accounts. Click OK after filling out the
account information for each user. Close the User Manager window.

5. After creating the accounts, right-click the MotorRPMSetPoint
button on the Compressor VI front panel and select Security.

User Name Password Security Level

Engineer Eng 7

Operator Oper 5
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6. Click Add. Double-click Engineer, and Operator. Click OK.

7. Configure each user’s access using the Access pull-down menu,
as shown in the following figure. Click OK.

8. Right-click the Login button and select Panel Wizard.

9. Select Login prompt. Click OK.

10. Click the Run button to run the VI.

11. Click the Login button on the front panel and log in as Operator.
The MotorRPMSetPoint knob does not appear because the Operator
user is not authorized to access it.

Note The passwords are case-sensitive.

12. Click the Login button again and log in as Engineer. Notice that
the MotorRPMSetPoint knob reappears because the Engineer is
authorized to adjust it.

13. Stop the VI. Save and close the VI.

Note You can also use the Security VIs, located on the Functions»System»Security
palette, to perform security operations.
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7
Networking

This chapter teaches you about networking a LabVIEW Datalogging and
Supervisory Control module application.

You will learn to do the following:

• Register network computers

• Import tags over the network

Note To complete these activities, you must have two computers connected by a network
to act as client and server.

Access I/O over the Network
To set up a client-server system you must register all of the network
computers, then import tags from the server machine and view them on the
client machine

Registering the Server Computer on the Client Machine
This activity demonstrates how to register a network computer with the
LabVIEW Datalogging and Supervisory Control module.

You can complete this activity in approximately 5 minutes.

Note To register or unregister a computer, you must be logged in as Administrator, or with
administrator privileges.

1. On the computer that will act as a client, select Tools»Datalogging &
Supervisory Control»Options, select the Advanced tab, then click
Registered Computers.

2. Click Add, select the server computer and click Register. Click OK to
close the Register Computer dialog box. Click OK again.
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Importing Tags to the Client Computer
This activity demonstrates how to access tags over the network.
Configuring the client involves adding tags from a configuration (.scf)
file from one or more server machines to an .scf file on the client.

You can complete this activity in approximately 7 minutes.

1. Select Tools»Datalogging & Supervisory Control»Show Toolbar
to display the Tag Utilities toolbar.

2. On the client computer, click the Tag button to invoke the Tag
Configuration Editor.

3. Select File»New and then File»Import Network Tags. The Select
Tags for Network Import dialog box prompts you for the network
path to the server .scf file.

Note File sharing must be enabled on the server computer to view files from the client
computer.

4. Click the Browse button in the Data Source SCF File field and
navigate to the server computer and the .scf file that contains the tags
you want to import.

5. Select the tags to import to the client computer .scf file and click Add
All. Click Import.
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6. Select File»Save and save the file as NetworkTags.scf. Click OK
in the SCF Logging Paths dialog box. Close the Tag Configuration
Editor.

7. Copy the Compressor VI from the server computer to the client
computer and open the VI.

8. Click the Run button to run the VI. Notice the server tags are displayed
on the client computer.

Tip Refer to the LabVIEW Datalogging and Supervisory Control Module Developer’s
Manual for information about creating and developing successful network applications.
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A
System Requirements

Platform Media and System Requirements

All Windows Platforms Distributed on CD-ROM.

LabVIEW Datalogging and Supervisory Control
module requires LabVIEW version 6.0 or later.

Refer to the installation instruction that appears on
your screen for information about the size of the
LabVIEW components you are installing.
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B
Technical Support Resources

Web Support
National Instruments Web support is your first stop for help in solving
installation, configuration, and application problems and questions. Online
problem-solving and diagnostic resources include frequently asked
questions, knowledge bases, product-specific troubleshooting wizards,
manuals, drivers, software updates, and more. Web support is available
through the Technical Support section of ni.com

NI Developer Zone
The NI Developer Zone at ni.com/zone is the essential resource for
building measurement and automation systems. At the NI Developer Zone,
you can easily access the latest example programs, system configurators,
tutorials, technical news, as well as a community of developers ready to
share their own techniques.

Customer Education
National Instruments provides a number of alternatives to satisfy your
training needs, from self-paced tutorials, videos, and interactive CDs to
instructor-led hands-on courses at locations around the world. Visit the
Customer Education section of ni.com for online course schedules,
syllabi, training centers, and class registration.

System Integration
If you have time constraints, limited in-house technical resources, or other
dilemmas, you may prefer to employ consulting or system integration
services. You can rely on the expertise available through our worldwide
network of Alliance Program members. To find out more about our
Alliance system integration solutions, visit the System Integration section
of ni.com
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Worldwide Support
National Instruments has offices located around the world to help address
your support needs. You can access our branch office Web sites from the
Worldwide Offices section of ni.com. Branch office Web sites provide
up-to-date contact information, support phone numbers, e-mail addresses,
and current events.

If you have searched the technical support resources on our Web site and
still cannot find the answers you need, contact your local office or National
Instruments corporate. Phone numbers for our worldwide offices are listed
at the front of this manual.
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